What are the minimal browser requirements for the Accuware dashboard?

Our dashboard currently works with:

  • Chrome (>= v.16.0.9 )
  • Firefox (>= v. 10.0.1)
  • Safari (>= v. 5.1.7 )